Pabau - API errors affecting UK and EU clinics – Incident details

Pabau Web Application (Desktop/Laptop) experiencing degraded performance

API errors affecting UK and EU clinics

Resolved
Partial outage
Started 23 days agoLasted about 3 hours

Affected

Pabau Web Application (Desktop/Laptop)

Degraded performance from 9:59 AM to 10:47 AM, Operational from 10:47 AM to 1:15 PM

Integrations

Partial outage from 9:59 AM to 10:47 AM, Operational from 10:47 AM to 1:15 PM

API

Partial outage from 9:59 AM to 10:47 AM, Operational from 10:47 AM to 1:15 PM

Updates
  • Resolved
    UTC
    Resolved

    Our team has implemented a fix, and the APIs are operating normally again.

    Thank you for your patience and understanding while we worked to resolve this.

  • Monitoring
    UTC
    Monitoring
    Recovered. API error rates returned to normal in both affected regions: UK clinics from 10:54 London, EU clinics from 11:26 London. Error rates have been at zero for the last 20 minutes with request volumes back to normal levels. US, Singapore and Australia regions were unaffected throughout. We are monitoring before marking this fully resolved.
  • Investigating
    UTC
    Investigating
    From 10:44 BST a proportion of GraphQL API requests failed for clinics served from our UK and EU regions. UK service recovered at 10:54 BST. EU is still degraded and we are actively investigating. US, Singapore and Australia regions are unaffected.