Update 06:10 UTC — the email backlog is draining, oldest first. Messages accepted 03:30–04:30 UTC have now fully cleared. The 04:30–05:00 UTC batch is down from 628 held to 149. Mail accepted after 05:00 UTC is still queuing, so some appointment confirmations and reminders are still arriving late. Nothing has been lost — these are delayed, not dropped, and they are being delivered as the queue clears. Next update by 08:10 UTC.
Investigating
UTC
Investigating
UTC
We are investigating delays affecting appointment-related emails (new appointment, reminder, booking confirmation and reschedule notices). Emails are being accepted and queued but are taking significantly longer than normal to reach recipients. Delivery is still flowing and no mail has been lost — affected messages are delayed, not dropped. Onset was approximately 04:30 BST today. We are working with our email delivery provider and will update within the hour.