Pabau - Postcode Address Lookup Returning No Results – Incident details

All systems operational

Postcode Address Lookup Returning No Results

Resolved
Degraded performance
Started 10 days agoLasted 2 days

Affected

Client Card

Degraded performance from 11:17 AM to 9:38 AM

Postcode Lookup

Degraded performance from 11:17 AM to 9:38 AM

Updates
  • Resolved
    Resolved

    This incident has now been resolved, and the postcode lookup feature is working as expected.

    The issue occurred because our previous address lookup provider, GetAddress, ceased trading in early February 2026 following legal and operational developments affecting their service. This resulted in the postcode lookup API no longer returning address data, which directly impacted our platform’s postcode address lookup functionality.

    As soon as this was identified, our team acted immediately to replace the underlying address lookup provider with a supported alternative. The new provider is fully integrated and operational, restoring postcode lookup functionality for all users.

    We apologise for the disruption this caused and thank you for your patience while we implemented the replacement and tested the solution.

  • Investigating
    Investigating

    We are aware of an issue affecting the postcode address lookup feature. When entering a postcode, address suggestions are not being returned as expected.

    Our development team has been notified and is currently investigating the cause. Further updates will be shared as we have more information.